< 返回版块

jonirrings 发表于 2019-06-25 14:54

Tags:diesel

以前倒腾过,但是老是忘记,于是写个帖子留个档。方便自己查,也方便有需要的盆友。

此贴建立的时候diesel_cli版本是v1.4.0

Win平台下安装diesel_cli

设置环境变量

我安装了EnterpriseDB出的Postgresql,里面带了libpq,另外装了wamp,里面也带了libmysqlclient,因此设置两个环境变量。

PQ_LIB_DIR=D:\Program Files\PostgreSQL\11\lib

MYSQLCLIENT_LIB_DIR=D:\wamp64\bin\mysql\mysql5.7.21\lib

LIB=%PQ_LIB_DIR%;%MYSQLCLIENT_LIB_DIR%;

如果要保证能运行,

PQ_BIN_DIR=D:\Program Files\PostgreSQL\11\bin

那还需要把PQ_BIN_BIN和LIB都加入到PATH内

运行命令

cargo install diesel_cli

就自动安装完了。sqlite的依赖在win下面走的是bundle,不需要单独引入。

Ubuntu下安装diesel_cli

运行命令

sudo apt-get install libmysqlclient-dev libsqlite3-dev libpq-dev
cargo install diesel_cli

评论区

写评论

还没有评论

1 共 0 条评论, 1 页